Error Reading Twits

Jan 28, 2009 at 4:05 PM
Edited Jan 28, 2009 at 4:07 PM
Update: Figured it out - looks like there needs to be additional checking when renaming a twitter username.... Let me know if you need details.

After logging in to Twitter, I get a unknown error type [object]. Any help would be much appreciated. Here's the log
[anon @ 1/28/2009 9:02:23 am » init¹ / util::gadget.init]  [CHECKPOINT] »» Chirpr v0.4.0.0
[anon @ 1/28/2009 9:02:23 am » init¹ / chirpr::chirpr.init]  [CHECKPOINT]
[anon @ 1/28/2009 9:02:35 am » save settings¹ / settings::[dialog session]]  [STARTING...]
[anon @ 1/28/2009 9:02:35 am » save settings¹ / settings::page.init]  [CHECKPOINT]
[leinerj @ 1/28/2009 9:02:40 am » save settings¹ / settings::[dialog session]]  [CHECKPOINT] »» settings saved
[leinerj @ 1/28/2009 9:02:40 am » init¹ / main::page.load]  [STARTING...] »» getting messages for first time...
[leinerj @ 1/28/2009 9:02:40 am » get messages¹ / main::page.messages.update]  [STARTING...] »» getting messages w/ refresh
[leinerj @ 1/28/2009 9:02:40 am » get messages¹ / main::page.messages.update]  getting latest messages, now...
[leinerj @ 1/28/2009 9:02:40 am » get messages¹ / chirpr::chirpr.twitter.getMessages]  [STARTING...]
[leinerj @ 1/28/2009 9:02:40 am » get messages¹ / chirpr::chirpr.twitter.getMessages]  getting messages: http://www.twitter.com/statuses/friends_timeline.json?count=20
[leinerj @ 1/28/2009 9:02:40 am » get messagesº / chirpr::chirpr.twitter.getMessages]  http send failed: 401 »» calling failure logic
[leinerj @ 1/28/2009 9:02:40 am » get messages¹ / chirpr::chirpr.twitter.getMessages[failed]]  [STARTING...] »» http=null, e=401
[leinerj @ 1/28/2009 9:02:40 am » get messagesº / main::page.messages.update]  [...FINISHED] »» error: [object Error]
[leinerj @ 1/28/2009 9:02:40 am » init¹ / main::page.load]  [...FINISHED]
[leinerj @ 1/28/2009 9:02:40 am » init¹ / main::page.load]  [CHECKPOINT]
[leinerj @ 1/28/2009 9:02:47 am » save settings¹ / settings::[dialog session]]  [STARTING...]
[leinerj @ 1/28/2009 9:02:47 am » save settings¹ / settings::page.init]  [CHECKPOINT]
[leinerj @ 1/28/2009 9:02:48 am » save settings¹ / settings::page.regions.init[log.load]]  load log region
Coordinator
Jan 28, 2009 at 4:50 PM
Twitter is saying your username and password is bad. Try verifying your credentials from the settings dialog. If that works, but you still can't get messages, let us know.

One other thing: is your password all numbers and starting with zero (0)? We should have fixed that issue, but let us know if that's the problem you're having. Just don't post your password.