Can't Even Log-In

Dec 17, 2008 at 8:57 AM
I'm a bit confused here. I just installed this gadget, and I put in my information, and it said everything was okay, verified correctly when varified, all of that. However, nothing happens afterward. I go back into the settings, and I see that my password is short one character. I correct it, same thing happens. Anyone know what's going on here?

Also, there's some odd pink thing behind the word "chirpr", Not sure if that's intentional or not, since it disappears sometimes.
Coordinator
Dec 17, 2008 at 5:54 PM
What version do you have? This is a very strange behavior. I haven't seen it happen before.

We know about the "odd pink thing." I lovingly called it "Predator Stealth Mode" because it reminds me of that see-through, but distorted stealth mode. We've tracked down what's causing it and plan on having a fix for that in the 0.5 release. It seems like an odd issue between the background image and the Sidebar. Either way, we'll fix it soon.

Thanks for getting in touch with us. Hopefully, we can figure out what's going on. While you're here, feel free to vote on the bugs and feature requests in the issue tracker ;-)
Dec 17, 2008 at 6:32 PM
Edited Dec 17, 2008 at 6:35 PM
, I'm using 0.3, the first one available on the releases page.

At first I thought the pink thing was supposed to be Chirpie and I felt like a jerk for bringing it up like a problem. XD

Thanks.

EDIT: I just tried it with 0.2, I'm getting the same thing, except this one up and tells me there's an unknown error.
Coordinator
Dec 18, 2008 at 6:43 AM
Try the 0.4 preview @ http://www.codeplex.com/chirpr/Release/ProjectReleases.aspx?ReleaseId=18616

I'm getting the feeling this is an environmental issue, tho. I can't imagine what would be causing this, but I haven't heard of anyone else having the issue. Very strange. If this doesn't work, I may have you dig into the Sidebar metadata to see what it's storing.

Don't ever feel bad about bringing up issues. As far as I'm concerned, we need our users telling us what they're seeing so we can make the gadget better for everyone. Keep the feedback rolling in! Good, bad, or indifferent.
Dec 18, 2008 at 12:51 PM
Hrm, that's always good to hear, heheh. Yeah, I tried 0.4 as well and no luck, and Chirpie is saying that there's an unknown error.
Coordinator
Dec 18, 2008 at 11:26 PM
Well, here's the good thing about 0.4... Go into settings, click the second image (picture of a notepad), and then click the "get help" link. That will open the troubleshooting page of our wiki. Just ignore that and come back here. Reply and paste (Ctrl+V) the contents of the clipboard into the message. When you click the "get help" link, we copy the log to the clipboard. Feel free to inspect it to be sure you're comfortable with what's in there. It shouldn't contain anything specific to you other than your Twitter username. Your password won't be in there. Let's see what that tells us.
Dec 19, 2008 at 1:21 AM

[anon @ 12/17/2008 9:19:11 pm » logging¹ / util::gadget.logging.clear]  cleared log »» log empty
[djkaton @ 12/17/2008 9:19:11 pm » save settings¹ / settings::page.regions.init[log.load]]  load log region
[djkaton @ 12/17/2008 9:19:13 pm » save settings¹ / settings::[dialog session]]  [CHECKPOINT] »» cancelled; no change
[djkaton @ 12/17/2008 9:19:31 pm » save settings¹ / settings::[dialog session]]  [CHECKPOINT] »» settings saved
[djkaton @ 12/17/2008 9:19:48 pm » init¹ / main::page.load]  [STARTING...] »» getting messages for first time...
[djkaton @ 12/17/2008 9:19:48 pm » get messages¹ / main::page.messages.update]  [STARTING...] »» getting messages w/ refresh
[djkaton @ 12/17/2008 9:19:48 pm » get messages¹ / main::page.messages.update]  getting latest messages, now...
[djkaton @ 12/17/2008 9:19:48 pm » get messages¹ / chirpr::chirpr.twitter.getMessages]  [STARTING...]
[djkaton @ 12/17/2008 9:19:48 pm » get messages¹ / chirpr::chirpr.twitter.getMessages]  getting messages: http://www.twitter.com/statuses/friends_timeline.json?count=20
[djkaton @ 12/17/2008 9:19:49 pm » get messagesº / chirpr::chirpr.twitter.getMessages]  http send failed: 401 »» calling failure logic
[djkaton @ 12/17/2008 9:19:49 pm » get messages¹ / chirpr::chirpr.twitter.getMessages[failed]]  [STARTING...] »» http=null, e=401
[djkaton @ 12/17/2008 9:19:49 pm » get messagesº / main::page.messages.update]  [...FINISHED] »» error: [object Error]
[djkaton @ 12/17/2008 9:19:49 pm » init¹ / main::page.load]  [...FINISHED]
[djkaton @ 12/17/2008 9:19:51 pm » get messages¹ / main::page.messages.update]  [CHECKPOINT] »» update skipped
[djkaton @ 12/17/2008 9:19:51 pm » get messages¹ / main::page.messages.update]  [CHECKPOINT] »» update skipped
[djkaton @ 12/17/2008 9:19:51 pm » get messages¹ / main::page.messages.update]  [CHECKPOINT] »» update skipped
[djkaton @ 12/17/2008 9:19:51 pm » get messages¹ / main::page.messages.update]  [CHECKPOINT] »» update skipped
[djkaton @ 12/17/2008 9:19:51 pm » get messages¹ / main::page.messages.update]  [CHECKPOINT] »» update skipped
[djkaton @ 12/17/2008 9:19:51 pm » get messages¹ / main::page.messages.update]  [CHECKPOINT] »» update skipped
[djkaton @ 12/17/2008 9:19:52 pm » save settings¹ / settings::[dialog session]]  [STARTING...]
[djkaton @ 12/17/2008 9:19:52 pm » save settings¹ / settings::page.init]  [CHECKPOINT]
[djkaton @ 12/17/2008 9:19:53 pm » save settings¹ / settings::page.regions.init[log.load]]  load log region
Coordinator
Dec 19, 2008 at 10:28 PM
Well, that didn't help. It's just telling me what we already know: Twitter's not letting you sign in. Let's just check what the gadget is saving.
  1. Start > Run... (or Win+R)
  2. Type %localappdata%\Microsoft\Windows Sidebar\Settings.ini and press Enter -- DO NOT POST THE CONTENTS OF THIS FILE
  3. Edit > Find... (Ctrl+F)
  4. Type tUserName= and press Enter
Here, you should see your Twitter username and password. Make sure they're correct. I'm guessing they're both missing the last character, like you mentioned before. If so, correct them and save the file. From here, re-open the settings dialog for Chirpr. If the username is correct, you should be good, so click OK. If it's not, completely close the Sidebar and restart it.

Let me know if this gets you anywhere.
Dec 20, 2008 at 12:45 AM
Hmm, that didn't work either. Oddly enough, both my username and password were correct in that file.

Random thought, my password begins with a 0, do you think the app may be ignoring that 0? That seems like something that would slip in coding to me.
Coordinator
Dec 20, 2008 at 6:07 PM
No, I don't think it has anything to do with what your password starts with; but you did give me an idea. I'm wondering if this has something to do with the special characters used in your password. I hate asking you this, but does your password contain any of the following characters: &=+%#? If so, don't tell me which one; just confirm/deny. I have a feeling the problem could be due to how the password is sent to Twitter.
Dec 20, 2008 at 7:13 PM
No, it doesn't. My password is just numbers, heh.
Coordinator
Dec 21, 2008 at 5:46 PM
Well, you've got me here... I have no idea what's going on. An all-numeric password shouldn't be a problem. I'll test it on my account to see if I have any problems, but I don't expect to.
Coordinator
Dec 21, 2008 at 6:19 PM
First off, I should ask if your password is at least 6 characters. Apparently, Twitter tells you your password was successfully changed if it's less than 6 characters, but it doesn't change. It took me a while to figure out what was going on there. Once I did change it to a 6+ number password, it worked both on twitter.com and in Chirpr. I'm still not sure what's going on for you.

To get this straight, you set your username and password, click OK, and Chirpr isn't able to connect. Then, you go back to settings and your password is one less character than you originally set it to, right? At this point, you set it to the correct value, click the check mark to validate the password, which is successful. You then click OK and get the same error. You may have to wait up to a minute for it to retry.

The only other thing I know to do is to give you a version of the gadget that logs the username and password to validate what's sent.
Dec 22, 2008 at 1:08 AM
My password is over 6 characters.

You've got the story right. I've waited quite a while to try it again before, but it keeps doing the same thing.

You really don't have to do that, I'd feel bad if you made a version specifically for me since I'm the only one who has this problem apparently D: (and I'd totally miss out on updates, heh heh)
Coordinator
Dec 22, 2008 at 2:01 AM
Bah, it's not that big of a deal. Of course, it's only this simple because of the work we put in for logging/troubleshooting. And, this is exactly the reason we did that. I just uploaded a version that will log the password it uses to connect. It works for me, so we'll see. After you set your password and click OK in settings, let Chirpr try to connect. Then, go back to settings, click on the second (Troubleshooting) menu icon, and look for a "main.messages.update" item, which should list your username and password. I probably should have made it easier, but we don't have the "jump to" feature added, yet.

http://www.codeplex.com/chirpr/Release/ProjectReleases.aspx?ReleaseId=18616
Dec 22, 2008 at 4:32 AM
baaah, just as I thought, it's skipping over that first 0 in my password. :S

Maybe it COULD be because of the number after it as well?
Coordinator
Dec 22, 2008 at 11:02 PM
Hmmm... I tried a password that started with 0, but I think that was when I wasn't using 6 characters. I just retried one and it failed. I can't dig into this tonight, but I'll take a closer look. I wonder if something is trying to convert the value to a number, which would trim the leading 0. I'll try to look at it tomorrow and let you know. Sorry for the issues. I just hope we can get to the bottom of this. Thanks for being so patient.
Dec 29, 2008 at 10:56 PM
Any updates on this? If you can't do anything, I'll probably just change my password to get it to work.
Coordinator
Dec 31, 2008 at 1:53 AM
Working on it, now. Sorry for the delay.
Coordinator
Dec 31, 2008 at 4:15 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.